GitHub

Download

<script src="//cdn.jsdelivr.net/npm/pouchdb@7.1.1/dist/pouchdb.min.js"></script>
<script>
  var db = new PouchDB('my_database');
</script>

PouchDB也可以直接下载:

如果您在Internet Explorer中使用PouchDB,则将需要Promise and Fetch polyfill.

PouchDB可以通过npm安装:

npm install --save pouchdb

安装后,请调用require()以使用它:

var PouchDB = require('pouchdb');
var db = new PouchDB('my_database');

PouchDB可以在Node或浏览器中使用. 使用浏览器需要捆绑器,例如BrowserifyWebpackRollup .

Browser only

如果仅在浏览器中使用PouchDB,则可以使用pouchdb-browser安装时间:

npm install --save pouchdb-browser
var PouchDB = require('pouchdb-browser');
var db = new PouchDB('my_database');

有关更多选项,请参见自定义版本 .

PouchDB托管在以下CDN上:

bower install --save pouchdb

对于过去的发行版和变更日志,请查看Github发行版页面 .

对于第三方插件,请参见插件页面 .

有关自定义构建和第一方插件,请参见自定义构建页面.

by  ICOPY.SITE